PUN Classic(PUN1이라고도 불립니다)은 PUN의 첫 버전입니다.         현재는 리팩토링 및 기능 확장에 의해 PUN2로 새롭게 바뀌었습니다.          새 프로젝트에는 PUN2를 이용해 주시고, 기존의 프로젝트도 가능하면 PUN1에서 PUN2로 옮기는 것을 권장합니다.  자세한 내용은: "마이그레이션 노트". PUN Classic은 곧 점검이 시작됩니다.        중요한 버그의 수정과 Unity의 신버전의 지원 등을 예정하고 있습니다. 신기능의 추가는 PUN2에서만 이루어지므로 주의해 주십시오.

IPv6

개념

IPv6 로의 전환은 필수적입니다. 애플도 IPv6의 앱과 업데이트만을 허용한다고 2016년 6월 1일에 결정 했습니다.

(상세 내용은 이 기사)를 읽어 보시는 것을 권장 합니다. 결과적으로 일부 개발자들은 걱정이 될 수 도 있습니다. 걱정하지 마세요. Photon 이 알아서 다 해줍니다. 완전하게 IPv6 로 전환하는 것은 매우 시간이 걸린다는 것을 알고 있습니다.

Photon 클라우드가 IPv4와 IPv6 클라이언트에서 접근 할 수 있는 이유입니다. 만약 Photon 클라우드에서 IPv6 를 사용하고 싶으면 올바른

PUN 과 Unity 버젼이 [여기]에 나와 있습니다(#ipv6andpun).
자신의 Photon 서버를 호스팅 하고 있으면 이 페이지에서 더 많은 것을 찾아 보세요.

Back To Top

IPv6 와 PUN

ExitGames 팀은 최대로 호환성을 지원하기 위하여 다양한 유니티 버전 지원을 위하여 매우 열심히 근무 하고 있습니다. 이에 관련된 몇가지 기억할 사항이 있습니다.:

  • PUN버전 1.68 부터 IPv6를 사용할 수 있습니다.
  • Unity 버전 5.3.4p4, 4.7.2, 5.1.5 과 5.2.5 부터 IPv6 를 지원 합니다. 유니티 블로그 포스트에서 확인 해 주세요.
  • 버전 1.69 부터 지원 합니다: PUN Free 와 PUN+ 는 Unity IPv6 를 지원하는 모든 iOS 내보내기를 지원 합니다.PUN+ 에서는 Unity 4.7.1 부터 IPv6를 지원 합니다.
  • "최적지역" 호스팅 유형은 버전 1.71 부터 사용할 수 있습니다.
  • 일반적으로 IP 주소보다는 호스트명을 사용하여 호스팅 타입을 설정하는 것을 권장 합니다. 몇 가지 경우에 있어서, IPv6-only 네트워크에서만 호스팅을 할 때 직접 서버의 IPv6 주소를 입력할 필요가 있습니다. 이 경우에는 PUN이 지원하는 올바른 IPv6 형식을 이용하시기 바랍니다. [address]:port.

기술문서 TOP으로 돌아가기